Plandroid Help Documentation

Importing an Image

Plandroid is most powerful when you are creating a design on top of a building floor plan image. This image needs to be in one of the image formats that the program can read, such as a GIF, PNG, JPEG/JPG, or PDF. If your customer has emailed you an image in one of these formats, you can import it right away with the Open plan image button in the Plan toolbox on the Design page. If you only have a fax or other hard copy of the house plan, you will need to scan the image in to your computer before you can open it with Plandroid.

Floor plan image cleaning tools
Plan tools

You can also drag-and-drop an image file into the Design -> Plan tool tab (or any other tool tab) to open it as the floor plan image. (Note that dropping an image into the Canvas instead of a tool tab will set it as a custom image, and not the floor plan image. However, you can convert a custom image to a floor plan image with the context menu item Convert to Plan Image.)

Once you have imported an image, you should immediately use the Plan -> Set scale tool (set scale tool) to scale your floor plan image. Enter any known dimension in the Distance field, and drag the Set scale tool over the part of the plan image that represents that distance. The program will then know the physical scale of the floor plan image for all subsequent calculations.

Remember that you can always draw a house plan from scratch with the Draw tools in the Design page, if you need to.

Note on Image Formats

Note that, in general, you are likely to have better quality images if your house plan images are in PNG, GIF, or PDF format. This is because these formats are not lossy, that is, the image data is compressed without discarding any of the image information. Images with sharp edges, such as a house plan, are best saved in these formats. Other popular formats, such as JPEG, can (depending on the image) have greater levels of compression - resulting in a smaller file size - but they do so by discarding information from the image. This can result in sharp edges becoming blurred and reducing the quality of your resulting design image. There is always a trade-off between image quality and file size.

Plandroid fully supports PDF image files. Note, however, that a PDF may contain image data in a raster format (where the image is stored in bits for each picture element (pixel), such as a bitmap), or in vector format (where the image is stored as lines), or a mixture of both. A raster image will become blurred if you zoom into it, while a vector image will remain crisp. The highest quality print images will be produced if you can obtain your house plan in vector format. Scanners will generally embed a raster image into the PDF files they produce.

Rasterizing a PDF Plan Image

There are times when it is helpful to convert a PDF plan image to a raster (fixed resolution) image. The pan and zoom response is often better for a raster image, less memory can be required in some cases, and only raster plan images can be flipped with the toolbar flip tools. The Tools menu item Tools -> Rasterize PDF Plan can be used to convert a PDF plan to a raster plan image.

The Rasterize PDF Plan tool lets you choose the resolution of the resulting plan image, so you can balance the memory use (or file size) against the resolution that suits your requirements.

Cleaning or Cropping an Image

You can cut, crop, rotate, and adjust the opacity (transparency) of the plan image you are using with the Plan tools. It is common to remove image artefacts, cluttering text or dimensions in this manner to make a professional presentation. The Cut tool cuts a quick rectangle in its normal mode, but if you hold down the [Alt] key you can cut an arbitrary polygon shape. Any region cut from a plan image can be pasted as a custom image back into the design with the toolbar Paste button (or [Ctrl] + V), as the image is automatically placed on the clipboard. The background colour to use for the editing operations can be picked directly from the plan image by holding the [Ctrl] key with any of these editing tools.

A cleaned house plan image
A house plan image

There is an example house plan image provided with the program installation (see the Quick Overview section for more details).

Making a Screen Grab

If you wish to import a design from some other package, such as a CAD program which does not allow you to save to PDF, then you can always do a screen grab. This is a slightly more complex process whereby you capture the image on your screen and save the image in one of the above formats that can be read by Plandroid. This is usually done with the aid of another software package. One way would be to use a dedicated screen grab program, such as the free software Screen Grab Pro. Another way would be to just press Print Scrn (to capture the whole screen), and paste it into an image program such as the excellent (and free) IrfanView. You can then save the image (using the IrfanView menu item File -> Save As, and choosing, for example, the .PNG format), and then import that file into Plandroid.

Using Your iPad / iPhone

A great way to create a floor plan is to use the MagicPlan iPad or iPhone app, available from the iTunes app store. This app uses augmented reality to measure and draw your floor plan by taking pictures of your house, which you can export in PDF, among other formats.

Go back to How do I?