Plandroid Help Documentation

Plandroid has a number of convenient tools, accessible from the Import and Tools menu items.

Import

Plan Image

This is exactly the same as the Design -> Plan -> Open plan image tool, and will open an image file (.gif, .jpg, .png, .pdf etc.) to use as the floor plan.

Design

This tool allows you to import the parts from a pre-existing design into a new plan. You can reuse a design you have already made for a new design with this tool, by taking the parts from the previous design and importing them into the present design. You can then move, rotate, and adjust the previous design to fit the requirements of your new design. This is particularly useful when you have a similar house plan to one you have already used before.

Catalog or Icon File

You can import a new parts catalog to the program with this menu item, and select it to use. You can also import a new or replacement icon image with this same tool.

Price Edits File

This tool lets you import a new pricing or price discount scheme to use for your catalogs. Complete details on how to set up your own pricing schemes are given in the section How Do I Edit Part Prices?

Report Template

You are able to browse to and insert a new report template using this menu item. You can also simply drag and drop a new template into the Report page -> Templates selection list. A template file must be in rich text format (RTF) for the program to read it. See Templates for more information.

Licence

You can use this tool to import a licence file for Plandroid. This is equivalent to the Import tool in the Help -> Licensing Info dialog box.

Insert Image

If you are on the Design or Report pages, then you can use this tool to find and insert an image file into your design or report document, respectively.

Tools

Resize Part

The Tools -> Resize Selected Part menu item allows you to resize a single selected part. You can change its size to that of any other part of the same sub-type, for example an outlet of size 285x285mm can be resized to 300x300mm. Only one part can be resized at a time, however any parts connected to the resized part will also be resized using the most suitable replacement parts in the catalog. If no appropriately sized part can be found, the connection will be broken. Therefore it is recommended that you check your design after performing a resize using the Check Design tool (check design tool). Note that you can also access this function from the Design page context menu.

Replace Parts

The Tools -> Replace Parts menu item allows you to replace all parts of a certain subtype, for example Metal Louvre Face Diffuser, with parts from a different subtype, for example Multivent Grille Diffuser. For each part, a replacement will be made if there is a part of the new subtype which matches the old subtype's size exactly. The program will report how many successful replacements were made, and if any parts could not be replaced. This tool can be used in the Design page, when it will replace all parts on the current level, or on the Costing page, where it will replace all parts on all levels (if you are using multiple levels). If you are on the Design page, then you also have the option of using the menu item Tools -> Replace From Selection. This will only replace parts from those parts you have currently selected, and means you have complete control over the replacement process.

Select Catalogs

The Select Catalogs tool lets you choose which catalogs you wish to load into the Parts Catalog Tab in the Design page. You can also import a new catalog into the program from this tool, or even import a pre-defined Catalog Edits file, with customised pricing information. See the Catalogs entry for more details.

Place Order

This tool allows you to directly place an order with your parts supplier, if your supplier is supported by the program. You need to have at least one part from the supported supplier in your design for this item to be usable. See How do I automatically place an order? for more information.

Rasterize PDF Plan

A PDF floor plan image may be in a raster (pixellated) format or a vector format (see How do I get a house plan? for a detailed discussion on image formats). Vector PDF images by their nature always have the highest possible image resolution. A rasterized image has a fixed resolution, and can look pixellated when printing or at increased zoom levels. However, there can be advantages to converting a vector PDF into a raster image. For example, the pan and zoom response is often better for a raster image, and the memory required can also be smaller (especially if you are only using one page of a multi-page PDF document). This tool lets you convert from a vector PDF to a raster image. You can control the level of detail that you wish to preserve in the raster image by specifying its size. As always, there is a trade-off between image detail and file size. Normally some trial and error is required to find an appropriate balance that suits your requirements.

If your PDF contains a raster image only, this tool will directly extract the image to its native resolution instead of requiring you to specify it.

Show Zones Table

This tool displays a table of all the load zones in your design, with an analysis of the required air flows in each zone. It is covered in detail in the Design Page documentation.

Save Report as Template

Your own edited report document can be saved directly as a Template for you to reuse with this tool. It will place your current document, without design data, in your list of report templates for you to use. This is the simplest way to create your own custom-made report templates.

Program Settings

You can clone your machine's configuration and duplicate it on a different machine with this tool. This is useful when you want to configure multiple instances of the program identically, or if you want to take a snapshot of your current configuration as a backup, for instance. The Export menu item will copy your program settings to a collection of files in a subdirectory of the directory you specify named Plandroid_Settings. The Import menu item will read any files in a settings directory back into Plandroid. The settings files include all the files needed to duplicate your current configuration, including your .config user settings and options, your price edit files, and all report templates. Any catalog files that you place in the settings directory are also imported. Some private settings, for example your SimPRO log in credentials, are excluded.

Options

Options are covered in detail in the Options section.